Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Dec 15, 2017 5:00 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 134 posts ]  Go to page Previous 14 5 6 7 8 9 Next
Author Message
PostPosted: Thu Dec 24, 2009 7:42 am 
Offline
Newbie

Joined: Mon Dec 21, 2009 9:00 am
Posts: 40
Hi

I try to install PCast into my terastation Pro, I had try to redownload a new version of the PCast and try differance commands the I get from this forums they are ./Update_PCast.sh and sh Update_PCast.sh "/"

the first command I try is (./Update_PCast.sh) I got the following

*********************************************************************
*********************************************************************
**************** PCAST upgrade starting ******
*********************************************************************
*********************************************************************


[INFO] Box seems to be a TeraStation Pro
[INFO] Stopping PCAST Daemons
Stop services: pcastd Scheduler
Scheduler: no process killed
[INFO] Installing PCAST files
tar: : Cannot chdir: No such file or directory
tar: Error is not recoverable: exiting now
cp: cannot stat `/fixes/pcastd': No such file or directory
[INFO] Activating PCAST entry in Web GUI
cp: cannot stat `/fixes/body_side_tspro_pcast.pl': No such file or directory
cp: cannot stat `/fixes/body_side_tspro_pcast.pl': No such file or directory

[INFO] Starting PCAST Daemons

/etc/init.d/httpd stop: httpd stopped
/etc/init.d/httpd start: httpd started

[INFO] Fixing Date/Time display bug at top of PCast menus

[INFO] Installing alternate theme - see README for details

*********************************************************************
*********************************************************************
****** PCAST upgrade finished ******
*********************************************************************
*********************************************************************


then I try the command of (sh Update_PCast.sh "/")then I got this message


*********************************************************************
*********************************************************************
**************** PCAST upgrade starting ******
*********************************************************************
*********************************************************************


[INFO] Box seems to be a TeraStation Pro
[INFO] Stopping PCAST Daemons
Stop services: pcastd Scheduler
Scheduler: no process killed
[INFO] Installing PCAST files
cp: cannot stat `//fixes/pcastd': No such file or directory
[INFO] Activating PCAST entry in Web GUI
cp: cannot stat `//fixes/body_side_tspro_pcast.pl': No such file or directory
cp: cannot stat `//fixes/body_side_tspro_pcast.pl': No such file or directory

[INFO] Starting PCAST Daemons

/etc/init.d/httpd stop: httpd stopped
/etc/init.d/httpd start: httpd started

[INFO] Fixing Date/Time display bug at top of PCast menus

[INFO] Installing alternate theme - see README for details

*********************************************************************
*********************************************************************
****** PCAST upgrade finished ******
*********************************************************************
*********************************************************************

root@TS-TGL99E:/mnt/disk2/phimle/terastation#

what is wrong there?? can anyone help please

thanks


Top
   
PostPosted: Thu Dec 24, 2009 11:28 am 
Offline
Moderator
User avatar

Joined: Tue Jul 26, 2005 5:22 pm
Posts: 1123
Location: United Kingdom
I'll have a look at this and assuming I find he issue I will upload a fixed download. What version of firmware is installed on the TeraStation Pro so I know what to test against?

Personally I nol onger use pCast as I prefer the uShare media server. As a result I would not notice any issues with the pCast install (although at one point I did use pCast on the the TSP) unless they are pointed out.


Top
   
PostPosted: Thu Dec 24, 2009 1:47 pm 
Offline
Newbie

Joined: Mon Dec 21, 2009 9:00 am
Posts: 40
I just install firmware 1.12 without AD support, it working well

I would like to use DLNA or UPnP but there is not enough information on your web site of how to install them.

is there any other simple way to make terastation Pro become a media server??

thanks


Top
   
PostPosted: Sun Jan 03, 2010 10:53 am 
Offline
Total Newbie

Joined: Sun Jan 03, 2010 10:45 am
Posts: 1
replicant wrote:
I was able to do the above easily..but I then wanted to compare PCast to twonky. When running the pcast install script I got the following.... any ideas what went wrong or how to fix it?

*********************************************************************
*********************************************************************
**************** PCAST upgrade starting ******
*********************************************************************
*********************************************************************


[INFO] Box seems to be a TeraStation Pro
[INFO] Installing PCAST files
tar: : Cannot chdir: No such file or directory
tar: Error is not recoverable: exiting now
cp: cannot stat `/fixes/pcastd': No such file or directory
[INFO] Activating PCAST entry in Web GUI
cp: cannot stat `/fixes/body_side_tspro_pcast.pl': No such file or directory
cp: cannot stat `/fixes/body_side_tspro_pcast.pl': No such file or directory

[INFO] Starting PCAST Daemons

/etc/init.d/httpd stop: httpd stopped
/etc/init.d/httpd start: httpd started

[INFO] Fixing Date/Time display bug at top of PCast menus
cp: copying multiple files, but last argument `/etc/pcast/theme_us/pcast' is not a directory
Try `cp --help' for more information.

[INFO] Installing alternate theme - see README for details
tar: /etc/pcast: Cannot chdir: No such file or directory
tar: Error is not recoverable: exiting now

*********************************************************************
*********************************************************************
****** PCAST upgrade finished ******
*********************************************************************
*********************************************************************

There are some issues in the Update_PCast.sh. You may modify this script then after that it run well. You also can try below one:
#!/bin/sh
#
# Name: Update_PCast.sh
#
# Description: Copy across and install PCAST files for the following
# OpenTera Original
# Home Server
# Pro
# Designed to be called from a master script that is
# controlling the overeall upgrade. Assumes that the
# script is being called from the root of the image
# it is trying to update.
# In fact for all machines except the Pro models this
# update has little effect except to correct the rather
# annoying bug where the date/time field displayed
#
# Change History:
# 02 Apr 2007 itimpi first version
# 04 Apr 2007 itimpi Avoid copying /usr/etc files unless
# they are missing (on TSPro only)
# 26 apr 2007 itimpi Avoid installing binaries on original/HS
# (only install fixes in these cases)


# The script can take one parameter which is the 'root' directory
# relative to which the changes must be applied. If omitted then
# the update is relative to /
BASEDIR=$1
VERBOSE="-v"

PCAST_FILES="PCast_ppc_tera_v3.tgz"

echo ""
echo "*********************************************************************"
echo "*********************************************************************"
echo "**************** PCAST upgrade starting ******"
echo "*********************************************************************"
echo "*********************************************************************"
echo ""

echo ""
# echo "#####################################################################"
# echo "# #"
# echo "# Adding new/updated binaries #"
# echo "# #"
# echo "#####################################################################"
# echo ""

# If start up files already exist then stop daemon during upgrade

SAVEPWD=`pwd`

if (test -f ${SAVEPWD}/PPC/${PCAST_FILES}) then
PCAST_FILES="PPC/${PCAST_FILES}"
elif (test ! -f ${SAVEPWD}/${PCAST_FILES}) then
cd ${SAVEPWD}
echo "[ERROR] You need to first get the PCAST files ${PCAST_FILES}"
echo "**** Aborting PCAST upgrade ****"
exit 1
fi
# If this is a TeraStation Pro then we need to copy in an
# amended perl file for use with the side-bar to get the
# PCAST entry to show up. On other models we do nothing
# as they are already set up for PCast.

case `grep "PRODUCTID" ${BASEDIR}/etc/linkstation_release | cut -d= -f2`
in
"0x00002001") echo "[INFO] Box seems to be a TeraStation (original)"
;;

"0x00002002") echo "[INFO] Box seems to be a TeraStation Pro"

if ( test -f /etc/init.d/pcastd ) then
echo "[INFO] Stopping PCAST Daemons"
/etc/init.d/pcastd "stop"
fi

echo "[INFO] Installing PCAST files"
tar -xzf ${PCAST_FILES} --directory=${SAVEPWD}
cp ${SAVEPWD}/fixes/pcastd ${BASEDIR}/etc/init.d
if ( test ! -d ${BASEDIR}/usr/etc ) then
mkdir ${BASEDIR}/usr/etc
fi
if ( test ! -f ${SAVEPWD}/fixes/mediaserver_accesscontrol.conf ) then
cp fixes/mediaserver_accesscontrol.conf ${BASEDIR}/usr/etc
cp fixes/mediaserver_accesscontrol.conf.bak ${BASEDIR}/usr/etc
cp fixes/mediaserver_discoveredclients.conf ${BASEDIR}/usr/etc
fi
echo "[INFO] Activating PCAST entry in Web GUI"
# check if it is just PCast or does it include printer as well?
if ( test -f /usr/bin/lp ) then
cp fixes/body_side_tspro_pcast_lp.pl ${BASEDIR}/www/cgi-bin/html/en/body_side.pl
cp fixes/body_side_tspro_pcast_lp.pl ${BASEDIR}/www/cgi-bin/html/jp/body_side.pl
else
cp fixes/body_side_tspro_pcast.pl ${BASEDIR}/www/cgi-bin/html/en/body_side.pl
cp fixes/body_side_tspro_pcast.pl ${BASEDIR}/www/cgi-bin/html/jp/body_side.pl
fi

echo ""
echo "[INFO] Starting PCAST Daemons"
echo ""
/etc/init.d/httpd "stop"
sleep 2
/etc/init.d/pcastd "start" 2>/dev/null 1>/dev/null
/etc/init.d/httpd "start"
;;

"0x00002003") echo "[INFO] Box seems to be a TeraStation Home Server"
;;

*) echo "[ERROR] Box type not recognized"
echo "**** Aborting PCAST upgrade ****"
;;
esac

echo ""
echo "[INFO] Fixing Date/Time display bug at top of PCast menus"
cp fixes/*.html ${BASEDIR}/etc/pcast/theme_us/pcast

echo ""
echo "[INFO] Installing alternate theme - see README for details"
tar -xzf pcast_theme_kdw.tgz --directory=${BASEDIR}/etc/pcast/

echo ""
echo "*********************************************************************"
echo "*********************************************************************"
echo "****** PCAST upgrade finished ******"
echo "*********************************************************************"
echo "*********************************************************************"
echo ""

exit 0


Top
   
PostPosted: Mon Jan 04, 2010 12:15 pm 
Offline
Newbie

Joined: Mon Dec 21, 2009 9:00 am
Posts: 40
Hi;

After I edit the Update_PCast.sh file according to your direction, I have the following errors messages.


root@TS-TGL99E:/mnt/disk2/phimle/terastation# sh Update_PCast.sh "/"

: command not found
: command not found
: command not found
: command not found
: command not found

*********************************************************************
*********************************************************************
**************** PCAST upgrade starting ******
*********************************************************************
*********************************************************************

: command not found

: command not found
: command not found
: command not found
'pdate_PCast.sh: line 54: syntax error near unexpected token `then
'pdate_PCast.sh: line 54: `if (test -f ${SAVEPWD}/PPC/${PCAST_FILES}) then
root@TS-TGL99E:/mnt/disk2/phimle/terastation# root@TS-TGL99E:/mnt/disk2/phimle/terastation# ./Upade_PCast
bash: root@TS-TGL99E:/mnt/disk2/phimle/terastation#: No such file or directory
root@TS-TGL99E:/mnt/disk2/phimle/terastation#

what I had done wrong???

thanks


Top
   
PostPosted: Mon Jan 04, 2010 12:32 pm 
Offline
Moderator
User avatar

Joined: Tue Jul 26, 2005 5:22 pm
Posts: 1123
Location: United Kingdom
I will be uploading a revised PCast package to my web site (based on the one that Buffalo make available on their GPL site) later today. You may be better off using that one?


Top
   
PostPosted: Wed Jan 06, 2010 9:10 am 
Offline
Newbie

Joined: Mon Dec 21, 2009 9:00 am
Posts: 40
Hi itimpi,

Have you upload a revised Pcast package get? I just re-download the Pcast package (both on OpenTera_v1 and PCast_PPc_tera_v3), unzip them then try to run the Update_PCast.sh again, same old errors message comeup.

May be I had download a wrong files. If you did already upload a revised Pcast package, can you point me to the correct link!

Thanks


Top
   
PostPosted: Wed Jan 06, 2010 9:35 am 
Offline
Moderator
User avatar

Joined: Tue Jul 26, 2005 5:22 pm
Posts: 1123
Location: United Kingdom
I am afraid not, but v4 should be there soon!

I thought I had it ready to upload, but then I reflashed my TSP back to a virgin state for testing and I found a bug that meant the web server for configuring PCast was not being activated unless you hand-edited a couple of configuration files. That bug has always been there even in the earlier releases, so I guess I must have originally done the hand-edits and forgotten about them.

I had two choices - either document the hand-edits or fix the Update script to do them automatically. I opted for the latter course as being less error-prone and was at the stage of testing the changes when I went to bed last night. The testing was looking OK so I should finish the testing this morning and get v4 of the package uploaded in a few hours time (there is heavy snow where I live so I am certainly not going to be distracted by going outside if I can help it:) ).

Sorry about the delay but at least it should mean the update installs and works correctly,

EDIT: I have found a bug where although everything apepars to have been installed correctly and the pages for configuring PCast and the PCast initial screen all appear correctly, media is not being served up correctly. I am trying to track down the reason. I suspect it is just a configuration issue but the problem is finding it.

Dave


Top
   
PostPosted: Thu Jan 07, 2010 8:41 pm 
Offline
Moderator
User avatar

Joined: Tue Jul 26, 2005 5:22 pm
Posts: 1123
Location: United Kingdom
The updated version of the PCast package (PCast_ppc_tera_v4) is now available for download. This installs without any error messages on my own TSPro system after it has been freshly flashed and is now delivering up media as expected.

Note, however, the issue mentioned in the README_PCast.txt file about checking that PCast has been configured as expected. I did not want to spend much time trying to resolve this issue as there is such a simple manual work-around when it occurs.

I also intend to put updated ushare files on the web site over the next few days as this is the media server I now tend to use in preference to PCast.

You mentioned that you were also looking at Twonky. I found this did not work for me as it ran out of memory trying to index my (large) media collection. Also it seems to be oriented to music rather than video. The final thing I did not like was that there was no folder browse mode in Twonky for finding and playing media - and folder browse mode seems essential in large media collections.


Top
   
PostPosted: Sat Jan 09, 2010 10:48 pm 
Offline
Newbie

Joined: Mon Dec 21, 2009 9:00 am
Posts: 40
Hi itimpi,

Thanks for your hard work on the PCast problem, I am very appreciated for your work, unfortunately it still not work for me.
after download a new version, unzip to Tera and run the command ./Update_Pcast.sh, I had the following errors

BUFFALO INC. TeraStation series TS-TGL(IENARI)

TS-TGL99E login: myroot
root@TS-TGL99E:~# cd /mnt/disk2/phimle/terastation
root@TS-TGL99E:/mnt/disk2/phimle/terastation# ls -l
total 17448
-rwxrw-rw- 1 nobody nogroup 2363 Jan 7 02:11 Build_PCast.sh
-rwxrw-rw- 1 nobody nogroup 17268561 Jan 7 07:41 PCast_ppc_tera_v4.tar.gz
-rwxrw-rw- 1 nobody nogroup 4651 Jan 8 02:18 README_PCast.txt
-rwxrw-rw- 1 nobody nogroup 6346 Jan 7 16:50 Update_PCast.sh
drwxrwxrwx 2 nobody nogroup 4096 Jan 10 08:22 fixes
-rwxrw-rw- 1 nobody nogroup 569527 May 7 2007 pcast_theme_kdw.tgz
root@TS-TGL99E:/mnt/disk2/phimle/terastation# ./Update_PCast.sh

*********************************************************************
*********************************************************************
**************** PCAST upgrade starting ******
*********************************************************************
*********************************************************************


[ERROR] You need to first get the PCAST files pcast_ppc_tera_v4.tar.gz
**** Aborting PCAST upgrade ****
root@TS-TGL99E:/mnt/disk2/phimle/terastation#

What I had done wrong???

you had mention about update the Ushare, may be I may wait for that. But I still want to try both, so if you can help! Please do, I am very appreciated.

thanks


Top
   
PostPosted: Sat Jan 09, 2010 11:14 pm 
Offline
Moderator
User avatar

Joined: Tue Jul 26, 2005 5:22 pm
Posts: 1123
Location: United Kingdom
I could have sworn I had corrected that issue as I had it when testing!

If you look there is a case mismatch between the file it is checking for and the file that is in the zip. Renaming the file to the correct case will let it continue.


Top
   
PostPosted: Sun Jan 10, 2010 12:13 am 
Offline
Newbie

Joined: Mon Dec 21, 2009 9:00 am
Posts: 40
thanks for your help, it working well now, I can see and activate PCast in my WEB GUl, my next step is going to test it with my DLink media player and PS3.

a last question, if I want to try Ushare, do I have to uninstall this PCast? if yes, can you tell how!

again thanks very much for your time. :up: :up: :up: :biglol: :biglol: :biglol:


Top
   
PostPosted: Sun Jan 10, 2010 5:57 am 
Offline
Moderator
User avatar

Joined: Tue Jul 26, 2005 5:22 pm
Posts: 1123
Location: United Kingdom
No - ushare is independent of POast (which is why I had not fixed the bugs on installing PCast earlier - I had not needed to for my personal use.).


Top
   
PostPosted: Sat Jan 16, 2010 11:05 pm 
Offline
Newbie

Joined: Mon Dec 21, 2009 9:00 am
Posts: 40
Hi Itimpl;

Sorry to border you again, the reason is that I try to connect wirelessly of my d-link dsm 320 media player which has UPnP buildin to my TeraPro which is connect to my home network via the rounder and this rounder has a WiFi.

the media player does not see the PCast server (I already enabled in my TeraPro)

so what is wrong here?, does PCast support UPnP?

any help will be very much appreciated.

thanks


Top
   
PostPosted: Sun Jan 17, 2010 3:19 am 
Offline
Moderator
User avatar

Joined: Tue Jul 26, 2005 5:22 pm
Posts: 1123
Location: United Kingdom
PCast DOES support UPNP, but not DLNA (some media players require this).

Did you check the configuration things mentioned in the README file that can stop PCast from running correctly even when it appears to be enabled via the GUI?

If you have logged in via telnet you can issue the following commands:
/etc/init.d/pcastd stop
/etc/init.d/pcastd start
Watch the information displayed by the second command to see if it makes sense. If not then probably one of the configuration items mentioned in the README file is not correct and needs to be manually configured.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 134 posts ]  Go to page Previous 14 5 6 7 8 9 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited