Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Aug 16, 2018 3:02 pm

All times are UTC+01:00

Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun Apr 14, 2013 2:44 pm 

Joined: Sun Apr 14, 2013 2:26 pm
Posts: 6
Hey Guys!

I'm new here and just inherited a TS Pro (v1 I believe based on my research/firmware flashing) and am having trouble installing the addons package. I've scoured the wiki and found some decent info in the forums but I've only seen about two other people run into this issue.

What's happening is I've flashed both 1.04 and 1.12 firmware with telnet+root access and each time I try to install the addons.tar package I recieve a "cannot execute binary file" when trying to run wget or other compliled code. Here's the output after a fresh flash of 1.04 while trying to install a better version of PS:

BUFFALO INC. TeraStation series TS-TGL(IENARI)

NAS login: root
root@NAS:~# cd /mnt/array1/NAS-Write
root@NAS:/mnt/array1/NAS-Write# tar -C / -xzvf addons.tar
root@NAS:/mnt/array1/NAS-Write# wget http://downloads.nas-central.org/Upload ... inaries/ps
bash: /usr/local/bin/wget: cannot execute binary file

I haven't dealt with Linux since college so this is a bit of a refresher course for me. Permissions at the file and folder level look correct at 755 for all files. I've taken ownership of the addons.tar package giving root user and group ownership to the file before installation. I've also tried installing wget manually with commands from their site but am running into a missing Sort and Make command issue - This lead me on a tangent of trying to install the GNU "basic" set of linux commands but ran into issues installing them as well.

The only thing I haven't tried is resetting to factory default via the web interface. My ultimate goal is to install media server capabilities to the device (like most everyone else wants with these I'm sure) but this is a HUGE roadblock to that goal. Has anyone else run into this issue or can someone give me a hand in figuring this out? Like I mentioned Linux/UNIX has been a while for me so I may need some commands typed out in full.

Thanks in advance for any help and sorry for the long winded post!

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 5 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited