Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Nov 23, 2017 12:26 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 17 posts ]  Go to page 1 2 Next
Author Message
 Post subject: LS-WTGL FullBrick
PostPosted: Sun Jan 31, 2016 11:14 pm 
Offline
Newbie

Joined: Wed Jan 06, 2016 10:09 am
Posts: 38
Hi!

Habe eine LS-WTGL mit FullBrick bekommen. Es wurde wohl uBoot komplett gelöscht. Sind hier Leute dabei, die das reparieren könnten? Glaube der Flash muss neu bespielt werden.


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Sun Jan 31, 2016 11:29 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Eigentlich sollte dir eine blinkende LED einen Fehlercode melden.

siehe:
http://www.nas-hilfe.de/buffalo-linkstation-pro-duo/fehlerbehebung/106-buffalo-linkstation-produo-ls-wtglr1-blinkt-und-piept-tftp-boot-recovery-durchfuehren


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Mon Feb 01, 2016 7:58 am 
Offline
Newbie

Joined: Wed Jan 06, 2016 10:09 am
Posts: 38
Nein, da blinkt leider nix mehr. Auch der Lüfter bleibt stumm... Im Grunde genommen passiert genau nichts wenn das Gerät Strom bekommt, auch wenn der Schalter korrekt auf Auto steht. Nur die Power LED ist durchgehend grün, und wenn ein Netzwerkkabel angesteckt ist blinkt diese.


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Mon Feb 01, 2016 10:01 am 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
hast eine PM


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Mon Feb 01, 2016 2:16 pm 
Offline
Newbie

Joined: Wed Jan 06, 2016 10:09 am
Posts: 38
Habe einen seriellen Port angelötet, passiert genau gar nichts. Hab das Teil gerade einen einen Metallschredder gesteckt! Problem gelöst ;-)


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Sat Feb 06, 2016 8:24 pm 
Offline
Newbie

Joined: Wed Jan 06, 2016 10:09 am
Posts: 38
So, LS-WTGL wurde durch 2 LS-QVL und einem LS-WXL abgelöst... Gab es extrem günstig in der Bucht :-)


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Sat Feb 06, 2016 9:32 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Feine Geräte und alle Macken sind bekannt.
Das Problem mit WD Green kennst du?


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Fri Feb 12, 2016 7:55 am 
Offline
Newbie

Joined: Wed Jan 06, 2016 10:09 am
Posts: 38
oxygen8 wrote:
Feine Geräte und alle Macken sind bekannt.
Das Problem mit WD Green kennst du?


Ich denke mal Du meinst die Kopfparkpanik?

Ich habe derzeit das LS-QVL mit 4x3TB WD-RED bestückt! Ich nutze kein RAID, sondern binde die Ordner zusammen. Debian "Jessie" ist installiert, alles nötigen Scripte von Hand geschrieben. Lüfter/leds/autoshutdown/wol/power button/function button etc. läuft auch wunderbar. Kernel ist derzeit ein angepasster 4.4er. Um SSH/SSHFS ein wenig zu beschleunigen habe ich openssh-7.1p2 mit den hpn patches kompiliert. Aber der CPU ist für cryptzeugs doch recht schwach!


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Fri Feb 12, 2016 11:42 am 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Die kleinste Terastation (TS1200D) bietet Verschlüsselung an und hat nur eine 3Watt CPU.
Da rechne ich mit 5 MB/s gegenüber 100MB/s ohne Verschlüsselung.
Aber wer es braucht, könnte es aktivieren.


Damit ich das verstehe, du hast jetzt auf den neueren Kirkwoods ein aktuelles Jessie installiert.
Welche fehlenden Funktionen haben dich dazu bewegt?


Ich nutze auf den Kirkwoods nur Optware für Erweiterungen.


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Fri Feb 12, 2016 1:16 pm 
Offline
Newbie

Joined: Wed Jan 06, 2016 10:09 am
Posts: 38
oxygen8 wrote:
Die kleinste Terastation (TS1200D) bietet Verschlüsselung an und hat nur eine 3Watt CPU.
Da rechne ich mit 5 MB/s gegenüber 100MB/s ohne Verschlüsselung.
Aber wer es braucht, könnte es aktivieren.


Für Kirkwood gibt es auch eine hardwarebeschleunigte Verschlüsselung. Nennt sich marvell_cesa oder mv_cesa.
Ich nutze keine Festplattenverschlüsselung auf den Kirkwoods. Ich nutze SSHFS, das verschlüsselt den Datentransfer.
Ich habe max. 9,5MB/s aber auch nur mit ein paar kniffen. Ich muss mal gucken was über FTP/CIFS unverschlüsselt geht.

Gestern habe ich an der LS-QVL mit 4 laufenden Festplatten ~27Watt gemessen. Bei 3 Platten im Standby sind es ~15Watt.

oxygen8 wrote:
Damit ich das verstehe, du hast jetzt auf den neueren Kirkwoods ein aktuelles Jessie installiert.
Welche fehlenden Funktionen haben dich dazu bewegt?


Ich habe einfach gern die volle Kontrolle über meine Systeme. Dafür brauche ich keine Weboberfläche.
Und Jessie lässt sich doch mit debootstrap total leicht installieren.


Mein richtiges NAS (Eigenbau) kopiert mit konstant ~105MB/s bei Komplettverschlüsselung (luks) sowie verschlüsseltem Datentransfer. Sind aber auch SSDs als Festplattencache verbaut. Das ist eine komplett andere Liga...


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Fri Feb 12, 2016 4:45 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Danke für die ausführliche Antwort.
Für Interessenten wäre es sehr schön, wenn du ein Howto basteln würdest.


mfg.
Oxy


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Fri Feb 12, 2016 7:12 pm 
Offline
Newbie

Joined: Wed Jan 06, 2016 10:09 am
Posts: 38
oxygen8 wrote:
Danke für die ausführliche Antwort.
Für Interessenten wäre es sehr schön, wenn du ein Howto basteln würdest.


mfg.
Oxy


Inwiefern? Grundinstallation Debian?


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Fri Feb 12, 2016 8:40 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Wenn man mit debootstrap debian auf dem NAS installiert, wird der Werkskernel weiter verwendet.
Du schreibst, du nutzt einen neueren.

Also musst du ihn irgendwo her haben.
Mit einem fremden Kernel dürfte vorerst weder die Lüftersteuerung, noch der Powertaster gehen.
Du schreibst ja ausfühlich, was alles geht, also gehe ich von Anpassungen aus.

So sah meine alte Anleitung aus:
http://forum.nas-hilfe.de/buffalo-technology-nas-anleitungen/debian-squeeze-auf-einer-linkstation-ohne-raid-ls-chlv2-ls-xhl-ls-vl-t1734.html
Und das halt in neu wäre nicht schlecht.


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Fri Feb 12, 2016 9:13 pm 
Offline
Newbie

Joined: Wed Jan 06, 2016 10:09 am
Posts: 38
oxygen8 wrote:
Wenn man mit debootstrap debian auf dem NAS installiert, wird der Werkskernel weiter verwendet.
Du schreibst, du nutzt einen neueren.


Wenn Du mit Werkskernel den originalen Buffalo Kernel meinst, dann Nein.
Ich habe komplett leere Platten verwendet und das Gerät mit einer Debian netconsole per tftp gebootet.

Ich rede als von einer kompletten Neuinstallation ohne das irgendwas von der originalen Buffalo Firmware benutzt wird.

oxygen8 wrote:
Also musst du ihn irgendwo her haben.

Jupp, selber kompiliert auf dem Kirkwood. Basis der Konfiguration war der Standardkernel in Jessie.
Ich habe kein cross-compile genutzt, weil ich lieber saubere deb Pakete haben wollte, was auch geklappt hat!
Dann hat man auch keine Probleme mit der Installation und die initrd wird auch sauber erstellt!

Die Kompilierung hat zwar viele Stunden gedauert, aber lieber so als Module kopieren und so krempel.

oxygen8 wrote:
Mit einem fremden Kernel dürfte vorerst weder die Lüftersteuerung, noch der Powertaster gehen.
Du schreibst ja ausfühlich, was alles geht, also gehe ich von Anpassungen aus.

Das Problem beim Standardkernel war an sich nur der DeviceTree, da es diesen einfach nicht gab für das LS-QVL.
Ich denke Du hast meinen Post gesehen, LS-QVL DeviceTree. Jedenfalls sollte dieser Patch in den Kernel 4.5 mit eingehen.
Habe das über Roger Shimizu hinzufügen lassen. Der kümmert sich um Kirkwood DeviceTrees.

Mit meinem DeviceTree wird alles sauber über gpio_fan/gpio_keys/leds_gpio angesteuert.

oxygen8 wrote:


Wie gesagt, ich mache eine komplette Neuinstallation, trotzdem Interessant?


Top
   
 Post subject: Re: LS-WTGL FullBrick
PostPosted: Fri Feb 12, 2016 9:21 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Das ist auf jeden Fall interessant.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 17 posts ]  Go to page 1 2 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited