Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sat Nov 18, 2017 7:12 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 71 posts ]  Go to page Previous 1 2 3 4 5 Next
Author Message
PostPosted: Thu Sep 22, 2016 9:08 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Raid 1 geht immer.
Bist ja unter 16TB.

Du hast nur wenige defekte Sektoren. Wo sie liegen wird darüber entscheiden, was noch zu retten ist.


Top
   
PostPosted: Thu Sep 22, 2016 9:11 pm 
Offline
Newbie

Joined: Wed Sep 21, 2016 8:09 pm
Posts: 29
oxygen8 wrote:
Raid 1 geht immer.
Bist ja unter 16TB.

Du hast nur wenige defekte Sektoren. Wo sie liegen wird darüber entscheiden, was noch zu retten ist.


Alles klar, ich harre mal der Dinge.

Vielen, vielen Dank schon mal bis hierher für den tollen Support!

:up:


Top
   
PostPosted: Fri Sep 23, 2016 6:38 am 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Mich würde noch interessieren, was du für Platten im NAS hattest.

Das gibt der Befehl aus:

kleines a

Code:
smartctl -a /dev/sdd


Top
   
PostPosted: Sat Sep 24, 2016 12:00 pm 
Offline
Newbie

Joined: Wed Sep 21, 2016 8:09 pm
Posts: 29
oxygen8 wrote:
Mich würde noch interessieren, was du für Platten im NAS hattest.

Das gibt der Befehl aus:

kleines a

Code:
smartctl -a /dev/sdd


Da ich sie jetzt nicht unnötigerweise nochmal vorm Backup anschließen will, gibts die Info vom HDD Label, sollte ja aufs selbe rauskomnen ;)

Sind zwo Seagate Momentus ST1000LM024... ja, ich weiß das Sind keine wirklichen NAS Platten aber das Prob wäre mit anderen Platten auch gekommen.


Top
   
PostPosted: Sat Sep 24, 2016 12:40 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Danke, ich dacht schon nur WD hatte das Problem.


Top
   
PostPosted: Sun Oct 02, 2016 2:26 pm 
Offline
Newbie

Joined: Wed Sep 21, 2016 8:09 pm
Posts: 29
Hallo oxygen8,

bin derweil endlich dabei die HDDs zu sichern! das neue NAS ist da und laeuft - nicht als RAID0 :mrgreen:

Das Backup-Image von /dev/sdc konnte bereits mittels ddrescue erfolgreich und ohne Errors erstellt werden.

Aktuell laeuft ddrescue nun fuer die andere Platte, also /dev/sdb, und es wurde auch schon relativ frueh ein Error gefunden. Errorsize ist mit 61440B angegeben und trat ungefaehr bei knapp 3000 MB auf.

XFS Repair soll dann spaeter beide Images pruefen und reparieren. Wie kann ich sie dann so einbinden, angenommen es konnte alles gefixt werden, sodass ich auch auf die Daten zugreifen kann?

Der Artikel unter https://netaddict.de/howtos:xfs-reparieren behandelt das Thema ja nur bei 1 Platte und nicht bei einem RAID0, sprich mit zwo *.dd Image-Files, wie ich sie dann vorliegen haben werde.

Danke!


Top
   
PostPosted: Sun Oct 02, 2016 4:32 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Die Anleitung sollte passen:
http://forum.nas-hilfe.de/buffalo-technology-nas-anleitungen/datenrettung-von-einer-linkstation-duo-t1872.html


Top
   
PostPosted: Tue Oct 04, 2016 7:39 pm 
Offline
Newbie

Joined: Wed Sep 21, 2016 8:09 pm
Posts: 29
So, ddrescue ist nun auch mit dem Backup der zweiten Platte fertig, nach fast 3 Tagen und 1649 Errors :? :o

Image

Allerdings haben beide dd Images dieselbe Groesse:

Image

Jetzt lasse ich erst mal XFS Repair drueber laufen oder?

z.B.:

Quote:
xfs_repair -f /mnt/DiskStation/backup_sdb6.dd


Korrekt?

Danke!


Top
   
PostPosted: Tue Oct 04, 2016 8:23 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Nein, falsch.

Auf den Platten ist mdadm und kein xfs.
Wenn du mit den 2 mdadm-Geräten ein Raid gestartet hast, kannst du darin das xfs finden.

das fehlt:

Code:
mdadm --assemble /dev/md0 /dev/sd[abcd]6


Top
   
PostPosted: Tue Oct 04, 2016 8:39 pm 
Offline
Newbie

Joined: Wed Sep 21, 2016 8:09 pm
Posts: 29
oxygen8 wrote:
Nein, falsch.

Auf den Platten ist mdadm und kein xfs.
Wenn du mit den 2 mdadm-Geräten ein Raid gestartet hast, kannst du darin das xfs finden.

das fehlt:

Code:
mdadm --assemble /dev/md0 /dev/sd[abcd]6


Aber die Platten (oder eine davon) verhindert ja aufgrund der ganzen defekten Sektoren das direkte Reparieren:

Quote:
sudo xfs_repair /dev/md0
Phase 1 - Superblock finden und überprüfen...
Lesen des Superblocks fehlgeschlagen, Versatz 1785006129152, Größe 131072, ag 29,
rval -1

schwerwiegender Fehler -- Eingabe-/Ausgabefehler


Deshalb sollte ich doch einen Klon jeder Platte ziehen und diesen dann reparieren. So hatte ich es in deinem Post auf S.2 verstanden


Top
   
PostPosted: Tue Oct 04, 2016 9:16 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
als Klon meinte ich eine neue Festplatte
Ich suche mal, wie man die Kopien einbinden kann.


Top
   
PostPosted: Tue Oct 04, 2016 9:32 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Code:
losetup /dev/loop0 /mnt/DiskStation/backup_sdb6.dd
losetup /dev/loop1 /mnt/DiskStation/backup_sdc6.dd


Danach poste mal die Ausgabe von
Code:
cat /proc/partitions


Top
   
PostPosted: Wed Oct 05, 2016 6:06 am 
Offline
Newbie

Joined: Wed Sep 21, 2016 8:09 pm
Posts: 29
Thx!

Image

scheint funktioniert zu haben... oder?


Top
   
PostPosted: Wed Oct 05, 2016 7:53 am 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
md0
ist schon gestartet!

poste mal die Ausgabe von

Code:
cat /proc/mdstat


Top
   
PostPosted: Wed Oct 05, 2016 6:28 pm 
Offline
Newbie

Joined: Wed Sep 21, 2016 8:09 pm
Posts: 29
oxygen8 wrote:
md0
ist schon gestartet!

poste mal die Ausgabe von

Code:
cat /proc/mdstat


Quote:
sudo cat /proc/mdstat
Personalities : [raid0]
md0 : active raid0 sdc6[0] sdb6[1]
1923496960 blocks super 1.2 512k chunks

unused devices: <none>


ist aber deshalb weil die beiden Platten auch noch drin haengen. Dachte ich fahre nochmal einen ddrescue Backup von /dev/md0 oder ist das unnoetig?

Wenn ich das abbrechen kann ohne Bedenken und du meinst die beiden Einzel-Images helfen mir auch, dann mache ich das gerne. Denn sonst warte ich jetzt wieder fast 3 Tage bis ddrescue fertig ist.

Danke.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 71 posts ]  Go to page Previous 1 2 3 4 5 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited