Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Aug 16, 2018 4:27 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 21 posts ]  Go to page Previous 1 2
Author Message
 Post subject: Re: Foonas on LS2
PostPosted: Sun Nov 11, 2007 3:04 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
try to boot foonas-em over tftp, maybe it works then

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
 Post subject: Re: Foonas on LS2
PostPosted: Sun Nov 11, 2007 5:00 pm 
Offline
Newbie

Joined: Wed Feb 21, 2007 6:11 pm
Posts: 24
thanks mindbender

but this also did notwork, u-boot is coming up with the following message:
Code:
nc -u -p 6666 192.168.11.150 6666

U-Boot 1.1.4 LiSt V2 (mips) 1.0.1 (Sep 20 2007 - 00:40:49)
stdin :   nc
stdout:   nc
stderr:   nc
IDE:    Bus 0: ........................OK Bus 1: OK
  Device 0: Model: WDC WD2500BB-22RDA0  Firm: 20.00K20 Ser#: W -DMWNA2K098173
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 238475.1 MB = 232.8 GB (488397168 x 512)
Boot in 01 seconds ('s' to stop)...


when I issue the tftpbootcommand the transfer times out, I have check 3 differnt tftp servers without success
Code:
=> tftpboot 192.168.11.149 vmlinuz.gz
tftpboot 192.168.11.149 vmlinuz.gz
Using rc32434_eth device
TFTP from server 192.168.11.149; our IP address is 192.168.11.150
Filename 'vmlinuz.gz'.
Load address: 0x192
Loading: #


When I change /boot/vmlinuz to link to/boot/vmlinux-2.6.22 and boot normal with uboot,uboot trys to boot the kernel but dies somewhere in between,and boot the standard 2.4 kernel.
Code:
U-Boot 1.1.4 LiSt V2 (mips) 1.0.1 (Sep 20 2007 - 00:40:49)
stdin :   nc
stdout:   nc
stderr:   nc
IDE:    Bus 0: ........................OK Bus 1: OK
  Device 0: Model: WDC WD2500BB-22RDA0  Firm: 20.00K20 Ser#: W -DMWNA2K098173
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 238475.1 MB = 232.8 GB (488397168 x 512)
Boot in 01 seconds ('s' to stop)...
Loading 0:1:boot/vmlinuz

1789270 bytes read
## Booting image at 82000000 ...
Found gzip-ed image at 0x82000000. Uncompressing ...done
Loading .text @ 0x80100000 (2841024 bytes)
Loading __ex_table @ 0x803b59c0 (6584 bytes)
Loading .rodata @ 0x803b8000 (223304 bytes)
Loading .pci_fixup @ 0x803ee848 (1320 bytes)
Loading __ksymtab @ 0x803eed70 (18448 bytes)
Loading __ksymtab_gpl @ 0x803f3580 (4664 bytes)
Loading __ksymtab_gpl_future @ 0x803f47b8 (24 bytes)
Loading __kcrctab @ 0x803f47d0 (9224 bytes)
Loading __kcrctab_gpl @ 0x803f6bd8 (2332 bytes)
Loading __kcrctab_gpl_future @ 0x803f74f4 (12 bytes)
Loading __ksymtab_strings @ 0x803f7500 (53616 bytes)
Loading __param @ 0x80404670 (860 bytes)
Loading .data @ 0x80406000 (123552 bytes)
Loading .data.cacheline_aligned @ 0x80425000 (192 bytes)
Loading .init.text @ 0x80426000 (141940 bytes)
Loading .init.data @ 0x80448a78 (12492 bytes)
Loading .init.setup @ 0x8044bb50 (744 bytes)
Loading .initcall.init @ 0x8044be38 (516 bytes)
Loading .con_initcall.init @ 0x8044c03c (8 bytes)
Loading .exit.text @ 0x8044c044 (3164 bytes)
Loading .init.ramfs @ 0x8044d000 (134 bytes)
Clearing .bss @ 0x8044e000 (119584 bytes)

Starting kernel @ 0x80426000...


any ideas ?


Top
   
 Post subject: Re: Foonas on LS2
PostPosted: Sun Nov 11, 2007 5:40 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
waterman, you've probably already checked this... but I'll ask just the same... for your tftp server... is it configured with the proper directory where the image is sitting (waiting to be transferred in)?

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
 Post subject: Re: Foonas on LS2
PostPosted: Sun Nov 11, 2007 6:14 pm 
Offline
Newbie

Joined: Wed Feb 21, 2007 6:11 pm
Posts: 24
I'm using http://sourceforge.net/projects/tftputil/ and have tried this with my Linux PC, and it worked - the firewall is turned off. The servers loggs 512 byte transferred and then responses a timeout. uboot is starting to get vmlinuz.gz, otherwise u-boots returns a message. What makes me wondering is that also booting from disk is not working, does this only working when u-boot is flashed ?


Top
   
 Post subject: Re: Foonas on LS2
PostPosted: Sun Nov 18, 2007 11:10 pm 
Offline
Moderator
User avatar

Joined: Thu Jun 22, 2006 10:54 pm
Posts: 240
Location: UK
Kaiten wrote:
If anyone experiences loss of networking after reboot/startup, try the following.

Boot into EM Mode. (3 clicks of the button or run bootcmd3 in u-boot)
Once in EM Mode:
Code:
cd /mnt/
mkdir helpme
mount /dev/hda1 /helpme
rm /mnt/helpme/var/run/ifstate
rm /mnt/helpme/var/run/smbd.pid
rm /mnt/helpme/var/run/nmbd.pid
rm /mnt/helpme/var/run/sshd.pid

Power off you box & restart as normal.


This should no longer be necessary the with the next lot of precompiled builds. Also hopefully fixed is the interfaces issue. Both of these are fixed in svn I just need to rebuild the mips stuff sometime.

_________________
Help the foonas fundraiser!

Click here for more information and donations


Top
   
 Post subject: Re: Foonas on LS2
PostPosted: Sun Nov 18, 2007 11:53 pm 
Offline
Developer
User avatar

Joined: Sun Dec 31, 2006 10:40 am
Posts: 434
Location: Scotland
timtim wrote:
This should no longer be necessary the with the next lot of precompiled builds. Also hopefully fixed is the interfaces issue. Both of these are fixed in svn I just need to rebuild the mips stuff sometime.
Hopefully & Thanks.. Looking forward to testing :)

_________________
LS-500GL - Diskless
LS-250GL - Armel, U-Boot NC Enabled
HS-DH320GL - Stock 1.11_1a
LS-H120LAN(PPC) - Dev (foonas)
LS-H120LAN(PPC) - Freelink - 2.6.23.8
LS-H250LAN(MIPS) - Dev (foonas-em, foonas)
LS-HS400DGL(PPC) - Freelink
Thecus N1200 - Ubuntu 8.10


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 21 posts ]  Go to page Previous 1 2

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited