Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Wed Jun 20, 2018 8:20 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Mon May 14, 2007 11:03 pm 
Offline
Newbie

Joined: Tue Feb 13, 2007 2:23 pm
Posts: 12
I keep getting bus errors. They always have ERRCS=0x002e, CEA=0x00000407.
I had a look in the kernel source as to why this is so.
It is only resetting the UCR (Undecoded CPU Read) and SAE (IPBus Slave Acknowledge Error) bits of ERRCS (ERRor Control and Status register), and is not resetting the CEA (Cpu Error Address). Almost all of the bits in ERRCS are sticky (IDT User Reference Manual, pages 4-2 to 4-4), and the CEA register is only set if it is 0xFFFFFFFF (IDT User Reference Manual, page 4-5)

However, the EPC and RA are possibly useful.
I'm getting errors in the following functions:
  • __copy_user
  • cdput
Called by the following functions:
  • do_generic_file_read
  • generic_file_write_nolock
  • dcache_readdir
  • cdput
  • __d_path
  • shrink_dcache_parent

My box has also been losing its marbles every few days. When this happens, the root filesystem becomes inaccessible, and logging in is impossible


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited