Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri May 25, 2018 5:46 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Tue Dec 08, 2009 7:53 am 
Offline
Newbie

Joined: Thu Dec 13, 2007 2:31 pm
Posts: 21
Hi,

Just did some trouble shooting since the Shihsung's uboot kernel can't boot on the LNI's u-boot.
Solution1:

The bug found is that when boot the uImage kernel, LNI's 1.1.4 u-boot has a hard coded kernel size after gzip limit at 0x400000 (only for the uImage part, the elf kernel size is coded at 0x800000 which is ok), should change to 0x800000.

Just chage one byte in the flash from 0x40 to 0x80 and it should work. (flash file at offset 0x96D1)

Solution2:
Of course upgrade Shihsung's new u-boot is working with uImage, but it is a pity that you probably will lost all your preconfiged boot enviroment by erase all the flash data area from BFC30000-BFC3FFFF. And it seem not able to boot elf kernel image as well. (might work by bootelf command, not tried)

ramp


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited