Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sun Aug 19, 2018 8:54 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 43 posts ]  Go to page 1 2 3 Next
Author Message
PostPosted: Tue Jun 27, 2006 5:27 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
What's the current status of the custom 2.6/MIPS kernels?


Top
   
PostPosted: Tue Jun 27, 2006 6:10 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
as far as i know someone got it compiled, but it did not load.
(he cross-compiled it besides)

i am not sure if the one tried the latest mips-loader.o from enji.
(he tells that it is beta in his opinion now, there were some problems with the pci-stuff that caused the kernel-loading to crash)

as we are now back in normal business in my opinion we could look into that again.

anyone with a LS2 out there that is willing to test?

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Tue Jun 27, 2006 10:26 am 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Yes as long as you have something to test. Previous trials have lead to box lock-ups

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Mon Jul 17, 2006 6:59 am 
Offline
Newbie

Joined: Fri Aug 26, 2005 2:28 am
Posts: 74
Location: Germany
Hello guys,

I'm willing to test new kernels/debil-versions on my LS2. My box is open and I connected another disk for testing (don't want to risk my data, the work on upgrading the HD, installing and configuring openlink). I'm willing to play around with partitioning and debil this week. I own a very cheap usb-webcam and would like to test it with LS2 (the cam worked with Knoppix 5.0.1). Is there a recomended partitioning scheme to avoid problems with space on /hda1? Could it be useful to make swap bigger? Could somebody point me to "the latest mips-loader.o from enji"? Any suggestions where to start?
Btw: I'm more an idiot than an expert, I've no coding experience. At least I could contribute some jpgs showing my LS2. Is there any need for special pictures?

-----------
LS2; Openlink 0.52b


Top
   
PostPosted: Mon Jul 17, 2006 7:02 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
The bootloader from my website should boot mips kernels as well.


Top
   
PostPosted: Mon Jul 17, 2006 8:27 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
If you've already dowloaded it, try again please. I forgot to include the MIPS code :(


Top
   
PostPosted: Mon Oct 09, 2006 3:33 pm 
Offline
Site Admin

Joined: Fri Aug 04, 2006 2:37 am
Posts: 1652
Location: United States of America
Don't mean to sound like a nuisance by asking this question, but what is the current status of kernel 2.6 for mips?

I am curious as to whether that guy (the one mindbender noted above) actually managed to get his kernel to boot. I am beginning to consider putting more serious efforts into compiling kernel 2.6 for mips, but I'd like to talk to the guys that actually made some full-hearted attempts and find out what they tried and what exactly went wrong.

I am pricing the LS Pro right now, about $230 USD for one w/ a 250gb hardrive. In a month or so (as I need to save so money up), I will purchase the LS Pro. Once the LS Pro is opened/hacked so I can make the LS Pro have the same/similar setup as my LS2 now, I will then use the LS2 for just compiling kernel 2.6 as now I also feel more comfortable doing so as kuroguy seems to be having success w/ JTAG and unbricking the LS2.

Thanks

_________________
http://www.opifer.net


Top
   
PostPosted: Mon Oct 09, 2006 4:43 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
it was bauldrick that managed to load a custom 2.4.20 kernel compiled from GPL Sources. it should be possible to create a newer kernel for the webinstaller....

you all know that i would look at this...but i have no LS2....tampakuro has my best hopes for JTAG....from that moment the box would be open again..

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Mon Oct 09, 2006 5:06 pm 
Offline
Site Admin
User avatar

Joined: Tue Mar 21, 2006 9:11 pm
Posts: 658
I'm not sure it would be worth the cost of shipping to send this LS2 back to Europe being as it is permanently partially bricked, doesn't have a hard drive, and the buttons don't (and likely never will) work. Of course, the pressure of trying to not brick it is somewhat reduced too.

I Should have some (good) news on the JTAG port by the end of the week and news on the serial console shortly after that.

_________________
My completely scratch built 832 push-pull tube amplifier with Padauk frame. It matches my custom mini-ITX machine.


Top
   
PostPosted: Mon Oct 09, 2006 6:31 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
can you please take a high quality photo of the board of the LS2 + upload it to the wiki?

i asked the guy who sold it if he can mark the things he has replaced....

kuroguy wrote:
Of course, the pressure of trying to not brick it is somewhat reduced too.

i personally think that this is more important. there would be far more grief if a fully functional LS2 would be killed ;)

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Mon Oct 09, 2006 6:35 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Bricking would not be a problem if we had the dual flash LS2 as you could just switch flashes. Shame we did not get it :(

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Mon Oct 09, 2006 7:01 pm 
Offline
Site Admin
User avatar

Joined: Tue Mar 21, 2006 9:11 pm
Posts: 658
If the half brick I have is not recoverable we could grab the flash chip out of it and make a dual flash unit. I can certainly manage the required soldering.

_________________
My completely scratch built 832 push-pull tube amplifier with Padauk frame. It matches my custom mini-ITX machine.


Top
   
PostPosted: Mon Oct 09, 2006 7:06 pm 
Offline
Site Admin
User avatar

Joined: Tue Mar 21, 2006 9:11 pm
Posts: 658
mindbender wrote:
can you please take a high quality photo of the board of the LS2 + upload it to the wiki?

I took pictures the other day. I just haven't put them up yet. I'll do that soon.

_________________
My completely scratch built 832 push-pull tube amplifier with Padauk frame. It matches my custom mini-ITX machine.


Top
   
PostPosted: Tue Nov 07, 2006 10:04 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
I just found the kernel I made

Eiji's loader with insmod (zImage) seems to come up but shortly after turns the box completely off.
1st press on power button does nothing (very worried at this point) second press turns it on, back to old kernel


Andre insmod (vmlinux) gives:

root@LINKSTATION2:/boot# insmod loaderII.o kernel=vmlinuxII.bin load_addr=0x80100000 start_addr=0x80286040

loaderII.o: loaderII.o: unresolved symbol _load_kernel_end
loaderII.o: loaderII.o: unresolved symbol _load_kernel_start

ah - I think I remember just renaming zImage.bin to vmlinux.bin ( It's a while back) - so it wouldn't load anyway?

root@LINKSTATION2:/boot# ls -l /boot/vmlinuxII.bin
-rwxr-xr-x 1 root root 778240 Nov 7 22:29 /boot/vmlinuxII.bin
root@LINKSTATION2:/boot# ls -l /boot/loader_mips/zImage.bin
-rwxr-xr-x 1 root root 778240 Nov 7 22:28 /boot/loader_mips/zImage.bin


My reason is I wanted to try something like the sekuro-box, but with a security cam on the door and see if the Linktheater would pick up the "live stream"(probably out of the realms of possibility and a massive longshot for me) .
OK - I've got an LS1 I might try it on - is it possible?

Anyway it seems developement was a bit dead for LS2 - could wake it up a bit!!

Eiji spoke of a patch for 2.6 for a different box with the same components, could it work?

http://buffalo.nas-central.org/forums/viewtopic.php?p=8588#p8588

Eiji wrote:
Hi

I found RouterBoard 532(@routerboard.com), which uses same CPU as LS2,
and it seems already works with Linux 2.6.

Discussion forum is at http://forum.routerboard.com/viewtopic.php?t=2996
Patch is also available. (But I dosen't test it yet.)
The patch includes CPU init, PCI init, and some RB532 specific codes.

On LS2, it still need to add some codes such as RTC, reboot, and shutdown, but
I think there is better way than codes from *pure* Linux 2.6.

How?


Top
   
PostPosted: Tue Nov 07, 2006 10:49 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
the serial port of the LS2 now could be very helpful now.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 43 posts ]  Go to page 1 2 3 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited