Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sat Nov 18, 2017 12:10 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Mon Aug 07, 2006 8:49 pm 
Offline
Newbie

Joined: Sun Jul 23, 2006 6:21 pm
Posts: 51
Location: Germany
Hello.

When I run smbpasswd from samba 3.0.23a on a MIPSEL system running Linux 2.4.20 as root, I'm NEVER asked for a password. Even when I create a new user in smbpasswd, I'm not asked:

Code:
root@HD.bei.digitalprojects.com:/etc/samba# strings smbpasswd 
root:0:AAD3B435B51404EEAAD3B435B51404EE:31D6CFE0D16AE931B73C59D7E0C089C0:[U          ]:LCT-44D63D42:
bin:1:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
daemon:2:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
adm:3:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
sync:5:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
nobody:99:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
root@HD.bei.digitalprojects.com:/etc/samba# smbpasswd -a askwar
Added user askwar.
root@HD.bei.digitalprojects.com:/etc/samba# smbpasswd askwar
root@HD.bei.digitalprojects.com:/etc/samba# strings smbpasswd
root:0:AAD3B435B51404EEAAD3B435B51404EE:31D6CFE0D16AE931B73C59D7E0C089C0:[U          ]:LCT-44D63D42:
bin:1:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
daemon:2:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
adm:3:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
sync:5:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
nobody:99:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU         ]:LCT-00000000:
askwar:1000:AAD3B435B51404EEAAD3B435B51404EE:31D6CFE0D16AE931B73C59D7E0C089C0:[U          ]:LCT-44D63EAE:[/pr e]

When I run smbpasswd as a user, eg. as Unix user "askwar", I AM prompted for a password.

[pre]askwar@HD.bei.digitalprojects.com:~/src/samba-3.0.23a/source$ smbpasswd
Old SMB password:


But as I don't know the "Old SMB password", I'm somewhat at a loss... :)

I also cannot feed the password over stdin as root:

Code:
root@HD.bei.digitalprojects.com:/etc/samba# echo foo | smbpasswd -s askwar 
Mismatch - password unchanged.
Unable to get new password.


What's happening here?

This happens with both the original smbpasswd and also with the smbpasswd I compiled myself for Samba 3.0.23a.

Alexander


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited